[archstudio-dev] Checked Out Version not displaying tools

Chris Wakibi wakibic at gmail.com
Thu Jul 2 07:31:46 PDT 2015


True, I picked up the updates am certain as I re-did everything afresh
about 3 hours ago. I am going to try it on Linux in about an hour and
revert. Thanks for the help.
Cheers
On 2 Jul 2015 17:28, "Scott Hendrickson" <sahendrickson at gmail.com> wrote:

> I think the other thing that was going on was that the code generation was
> still inserting illegal characters. I got that fixed last night and it was
> published to the update site in the last 7 hours. So, I'm curious if you
> also picked up the update when you installed the other components.
>
> Regardless, I'm glad that you got it working. And, I apologized for not
> getting back to you earlier; I just missed the e-mail. If you run into
> other problems, or the source is unclear (it is poorly documented), feel
> free to continue sending e-mails to this group. Also, if I don't respond
> within 24 hrs please ping me again.
>
> -- Scott
>
>
> On Thu, Jul 2, 2015 at 6:04 AM, Chris Wakibi <wakibic at gmail.com> wrote:
>
>> Hi Scott,
>>
>> I finally managed to have it work. This is what I did (not sure if you
>> had rectified it by the time it worked at my end)
>>
>> - Install Eclipse Modeling Tools version (
>> https://www.eclipse.org/downloads/download.php?file=/technology/epp/downloads/release/mars/R/eclipse-modeling-mars-R-win32-x86_64.zip
>> )
>> - Install  EMF - Eclipse Modeling Framework SDK
>> - Install Xtend and all related plugins
>> - Install XSD (It comes pre-installed if you are using Eclipse Modelling
>> tools version)
>> - Install ArchStudio (both the ArchStudio and ArchStudio Optional)
>> - Checkout development version as per tutorial here
>> <http://isr.uci.edu/projects/archstudio/setup-fromsource.html>
>> And it worked like a charm. Time is not on my side, but I wanted to try
>> and keep skipping one of the steps I followed just so as to get the bare
>> minimum that will make this work.
>>
>> Cheers - Chris
>>
>>
>> On Thu, Jul 2, 2015 at 8:47 AM, Chris Wakibi <wakibic at gmail.com> wrote:
>>
>>> Thank you Scott.
>>> Patiently waiting.
>>>
>>> -- Chris
>>> On 2 Jul 2015 05:02, "Scott Hendrickson" <sahendrickson at gmail.com>
>>> wrote:
>>>
>>>> Hi Chris,
>>>>
>>>> I just saw this and your other e-mail. I'm looking into it and will get
>>>> back to you.
>>>>
>>>> -- Scott
>>>>
>>>> On Wed, Jul 1, 2015 at 9:56 AM, Chris Wakibi <wakibic at gmail.com> wrote:
>>>>
>>>>> Hello Everyone,
>>>>>
>>>>> I am trying to extend ArchStudio5. I have gone through the whole
>>>>> process of checking out a development version, but the resulting projects
>>>>> still have errors.
>>>>> A good number of these errors are in the *MyxComponentStub.java files.
>>>>> The errors are more like "Syntax error on token 'import'....". From what I
>>>>> understand, these files are generated automatically. Do I have some plugins
>>>>> missing on my system?
>>>>>
>>>>> And when I "force" the Checked out version to run, there are no tools
>>>>> i.e AIMLauncher, ArchEdit, Archipelago and Archlight are not displayed.
>>>>>
>>>>> Kindly help me with that, or point me in the right direction. I have
>>>>> tried uninstalling, re-installing like 10 times today only, still no luck.
>>>>>
>>>>> Cheers - Chris
>>>>>
>>>>> _______________________________________________
>>>>> archstudio-dev mailing list
>>>>> archstudio-dev at uci.edu
>>>>> https://maillists.uci.edu/mailman/listinfo/archstudio-dev
>>>>>
>>>>>
>>>>
>>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://maillists.uci.edu/pipermail/archstudio-dev/attachments/20150702/772e3b49/attachment.html>


More information about the archstudio-dev mailing list